Versions affected

  • All ODP versions
  • All OXM versions
  • All DCH versions
  • XCRO 6.x and above


Abstract

Kubenetes 1.16 was announced on September 18th, and among the changes that went into 1.16 were significant improvements to the Kubernetes API. Omni-Data Platform (ODP) uses Kubenetes APIs under the hood. These API changes in Kubernetes 1.16 leaves ODP unsupported on Kubernetes 1.16 as of 1st October, 2019.


Impact and resolution

For all released versions of ODP, the maximum supported version of Kubernetes has been capped at 1.15. All current versions of ODP will continue to support Kubernetes from 1.11 to 1.15.